Contact us

System Requirements

  •   Intel Pentium II processor ( Pentium III or higher recommended)
  •   Windows 98, SE, NT4, ME, 2000, XP or higher
  •   128 MB of installed RAM
  •   Internet Browser (choose one)
  •   Microsoft Internet Explorer 6 or later
  •   Mozilla 1.4 or later
  •   Mozilla Firefox 0.7 or later
  •   Netscape 7 or later
  •   Macromedia Shockwave Player 8.5 or later
  •   Speakers or headphones
  •   Microphone or headset with headphones and microphone
  •   Quick Time Player

 

Special note: Currently the application is not compatible with Mac.